summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>2017-01-31 17:03:38 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-01 22:04:49 +0100
commit497f69889d21200e55a7519cf64819e9ce6e59cd (patch)
treec7a9d04c523449c78ce007833bd3500ca2057320 /toolchain
parentd995fd1258a3b48ee5eae3dd3e0beb1d27c7f449 (diff)
toolchain-external: remove stale references to (ARCH_)LIBC_A_LOCATION
The variables LIBC_A_LOCATION and ARCH_LIBC_A_LOCATION were killed in commit 646bd86908f7f995cdc2b95e0be381d97600f905 but the corresponding descriptions were never removed. Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/pkg-toolchain-external.mk30
1 files changed, 11 insertions, 19 deletions
diff --git a/toolchain/toolchain-external/pkg-toolchain-external.mk b/toolchain/toolchain-external/pkg-toolchain-external.mk
index e0a8b410c..665887500 100644
--- a/toolchain/toolchain-external/pkg-toolchain-external.mk
+++ b/toolchain/toolchain-external/pkg-toolchain-external.mk
@@ -347,35 +347,27 @@ endef
#
# Variables are defined as follows:
#
-# LIBC_A_LOCATION: location of the libc.a file in the default
-# multilib variant (allows to find the main
-# sysroot directory)
-# Ex: /x-tools/mips-2011.03/mips-linux-gnu/libc/usr/lib/libc.a
-#
-# SYSROOT_DIR: the main sysroot directory, deduced from
-# LIBC_A_LOCATION by removing the
-# usr/lib[32|64]/libc.a part of the path.
+# SYSROOT_DIR: the main sysroot directory, deduced from the location of
+# the libc.a file in the default multilib variant, by
+# removing the usr/lib[32|64]/libc.a part of the path.
# Ex: /x-tools/mips-2011.03/mips-linux-gnu/libc/
#
-# ARCH_LIBC_A_LOCATION: location of the libc.a file in the selected
-# multilib variant (taking into account the
-# CFLAGS). Allows to find the sysroot of the
-# selected multilib variant.
-# Ex: /x-tools/mips-2011.03/mips-linux-gnu/libc/mips16/soft-float/el/usr/lib/libc.a
-#
# ARCH_SYSROOT_DIR: the sysroot of the selected multilib variant,
-# deduced from ARCH_LIBC_A_LOCATION by removing
-# usr/lib[32|64]/libc.a at the end of the path.
+# deduced from the location of the libc.a file in the
+# selected multilib variant (taking into account the
+# CFLAGS), by removing usr/lib[32|64]/libc.a at the end
+# of the path.
# Ex: /x-tools/mips-2011.03/mips-linux-gnu/libc/mips16/soft-float/el/
#
# ARCH_LIB_DIR: 'lib', 'lib32' or 'lib64' depending on where libraries
-# are stored. Deduced from ARCH_LIBC_A_LOCATION by
-# looking at usr/lib??/libc.a.
+# are stored. Deduced from the location of the libc.a file
+# in the selected multilib variant, by looking at
+# usr/lib??/libc.a.
# Ex: lib
#
# ARCH_SUBDIR: the relative location of the sysroot of the selected
# multilib variant compared to the main sysroot.
-# Ex: mips16/soft-float/el
+# Ex: mips16/soft-float/el
#
# SUPPORT_LIB_DIR: some toolchains, such as recent Linaro toolchains,
# store GCC support libraries (libstdc++,