summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-07-04 13:26:35 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-07-04 14:55:06 +0200
commitc1d90e9bb7ad1b9737db9f6476a5bdaa27a9fa8a (patch)
treec7d2c4c90ba46b0d1350b235bffe4c73ca5700d5 /toolchain
parent54069ccabe7b6fe984bfbb781797f6447fd41a95 (diff)
toolchain-external: wrap gfortran
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/toolchain-external.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/toolchain-external/toolchain-external.mk b/toolchain/toolchain-external/toolchain-external.mk
index a31a04be3..c103b96c9 100644
--- a/toolchain/toolchain-external/toolchain-external.mk
+++ b/toolchain/toolchain-external/toolchain-external.mk
@@ -729,9 +729,9 @@ define TOOLCHAIN_EXTERNAL_INSTALL_TARGET_BFIN_FLAT
endef
endif
-# Build toolchain wrapper for preprocessor, C and C++ compiler and setup
-# symlinks for everything else. Skip gdb symlink when we are building our
-# own gdb to prevent two gdb's in output/host/usr/bin.
+# Build toolchain wrapper for preprocessor, C, C++ and Fortran compilers
+# and setup symlinks for everything else. Skip gdb symlink when we are
+# building our own gdb to prevent two gdb's in output/host/usr/bin.
# The LTO support in gcc creates wrappers for ar, ranlib and nm which load
# the lto plugin. These wrappers are called *-gcc-ar, *-gcc-ranlib, and
# *-gcc-nm and should be used instead of the real programs when -flto is
@@ -746,7 +746,7 @@ define TOOLCHAIN_EXTERNAL_INSTALL_WRAPPER
*-ar|*-ranlib|*-nm) \
ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%../..%') .; \
;; \
- *cc|*cc-*|*++|*++-*|*cpp) \
+ *cc|*cc-*|*++|*++-*|*cpp|*-gfortran) \
ln -sf toolchain-wrapper $$base; \
;; \
*gdb|*gdbtui) \