summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--boot/uboot/Config.in8
-rw-r--r--boot/uboot/uboot.mk4
2 files changed, 12 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index d46a75768..fabf27db7 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -137,6 +137,14 @@ config BR2_TARGET_UBOOT_NEEDS_DTC
Select this option if your U-Boot board configuration
requires the Device Tree compiler to be available.
+config BR2_TARGET_UBOOT_NEEDS_OPENSSL
+ bool "U-Boot needs OpenSSL"
+ help
+ Select this option if your U-Boot board configuration
+ requires OpenSSL to be available on the host. This is
+ typically the case when the board configuration has
+ CONFIG_FIT_SIGNATURE enabled.
+
menu "U-Boot binary format"
config BR2_TARGET_UBOOT_FORMAT_AIS
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 86e5b84d9..ae7539d51 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -133,6 +133,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)
UBOOT_DEPENDENCIES += host-dtc
endif
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSSL),y)
+UBOOT_DEPENDENCIES += host-openssl
+endif
+
# prior to u-boot 2013.10 the license info was in COPYING. Copy it so
# legal-info finds it
define UBOOT_COPY_OLD_LICENSE_FILE