summaryrefslogtreecommitdiff
path: root/boot/barebox/barebox.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/barebox/barebox.mk')
-rw-r--r--boot/barebox/barebox.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 832297eef..7a110d214 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -61,6 +61,8 @@ else ifeq ($$(KERNEL_ARCH),x86_64)
$(1)_ARCH = x86
else ifeq ($$(KERNEL_ARCH),powerpc)
$(1)_ARCH = ppc
+else ifeq ($$(KERNEL_ARCH),arm64)
+$(1)_ARCH = arm
else
$(1)_ARCH = $$(KERNEL_ARCH)
endif