summaryrefslogtreecommitdiff
path: root/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk')
-rw-r--r--boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk b/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
index c56bdeeea..a46937538 100644
--- a/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
+++ b/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
@@ -30,6 +30,12 @@ BOOT_WRAPPER_AARCH64_CONF_OPTS = \
--with-kernel-dir=$(LINUX_DIR) \
--with-cmdline=$(BR2_TARGET_BOOT_WRAPPER_AARCH64_BOOTARGS)
+ifeq ($(BR2_TARGET_BOOT_WRAPPER_AARCH64_PSCI),y)
+BOOT_WRAPPER_AARCH64_CONF_OPTS += --enable-psci
+else
+BOOT_WRAPPER_AARCH64_CONF_OPTS += --disable-psci
+endif
+
# We need to convince the configure script that the Linux kernel tree
# exists, as well as the DTB and the kernel Image. Even though those
# are available on the build machine, the configure script uses