summaryrefslogtreecommitdiff
path: root/boot/uboot/uboot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/uboot/uboot.mk')
-rw-r--r--boot/uboot/uboot.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index ae7539d51..3e347c108 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -181,6 +181,12 @@ endif # BR2_TARGET_UBOOT_USE_DEFCONFIG
UBOOT_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
UBOOT_KCONFIG_OPTS = $(UBOOT_MAKE_OPTS)
+define UBOOT_HELP_CMDS
+ @echo ' uboot-menuconfig - Run U-Boot menuconfig'
+ @echo ' uboot-savedefconfig - Run U-Boot savedefconfig'
+ @echo ' uboot-update-defconfig - Save the U-Boot configuration to the path specified'
+ @echo ' by BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE'
+endef
endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
define UBOOT_BUILD_CMDS