summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in8
-rw-r--r--linux/linux.mk2
2 files changed, 10 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index ce55271c9..be6d0ccbc 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -142,6 +142,14 @@ choice
config BR2_LINUX_KERNEL_USE_DEFCONFIG
bool "Using an in-tree defconfig file"
+config BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG
+ bool "Use the architecture default configuration"
+ help
+ This option will use the default configuration for the
+ selected architecture. I.e, it is equivalent to running
+ "make ARCH=<foo> defconfig". This is useful on architectures
+ that have a single defconfig file, such as ARM64.
+
config BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG
bool "Using a custom (def)config file"
diff --git a/linux/linux.mk b/linux/linux.mk
index a751da93b..fb844ef7a 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -206,6 +206,8 @@ LINUX_POST_PATCH_HOOKS += LINUX_TRY_PATCH_TIMECONST
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
LINUX_KCONFIG_DEFCONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG))_defconfig
+else ifeq ($(BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG),y)
+LINUX_KCONFIG_DEFCONFIG = defconfig
else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
LINUX_KCONFIG_FILE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
endif