summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/helpers.mk3
-rw-r--r--toolchain/toolchain-external/toolchain-external-custom/Config.in.options11
2 files changed, 12 insertions, 2 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 3991bc1cf..72e729235 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -145,8 +145,7 @@ check_kernel_headers_version = \
check_gcc_version = \
expected_version="$(strip $2)" ; \
if [ -z "$${expected_version}" ]; then \
- printf "Internal error, gcc version unknown (no GCC_AT_LEAST_X_Y selected)\n"; \
- exit 1 ; \
+ exit 0 ; \
fi; \
real_version=`$(1) --version | sed -r -e '1!d; s/^[^)]+\) ([^[:space:]]+).*/\1/;'` ; \
if [[ ! "$${real_version}" =~ ^$${expected_version}\. ]] ; then \
diff --git a/toolchain/toolchain-external/toolchain-external-custom/Config.in.options b/toolchain/toolchain-external/toolchain-external-custom/Config.in.options
index cdc25559f..5ff2491e1 100644
--- a/toolchain/toolchain-external/toolchain-external-custom/Config.in.options
+++ b/toolchain/toolchain-external/toolchain-external-custom/Config.in.options
@@ -59,6 +59,17 @@ config BR2_TOOLCHAIN_EXTERNAL_GCC_4_3
bool "4.3.x"
select BR2_TOOLCHAIN_GCC_AT_LEAST_4_3
+config BR2_TOOLCHAIN_EXTERNAL_GCC_OLD
+ bool "older"
+ help
+ Use this option if your GCC version is older than any of the
+ above.
+
+ Note that the Buildroot community doesn't do any testing with
+ such old toolchains. Some packages may fail to build in
+ surprising ways, or the generated root filesystem may not
+ work at all. Use such old toolchains at your own risk.
+
endchoice
choice