summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-07-25 16:04:32 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2012-07-25 17:59:58 +0200
commit3b0f80308a033633be6b903fa2a55128dfd99339 (patch)
treeb2e6e54f15a3cc3435ce2431b24b1bc946bfb794 /Makefile.am
parentefa5e355ac371d749cf505b952b900d05f25474c (diff)
build: Make autoreconf honour ACLOCAL_FLAGS
When running autoreconf, it's possible to give flags to the underlying aclocal by declaring a ACLOCAL_AMFLAGS variable in the top level Makefile.am. Putting ${ACLOCAL_FLAGS} there allows the user to set an environment variable up before running autogen.sh and pull in the right directories to look for m4 macros, say an up-to-date version of the xorg-util macros. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cd724c4..5ea0fd87 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,8 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
+
SUBDIRS = lib man tools scripts tests benchmarks demos
if BUILD_SHADER_DEBUGGER