summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2013-01-21 23:02:36 +0000
committerDamien Lespiau <damien.lespiau@intel.com>2013-03-04 15:54:35 +0000
commit5435708a50beb0368ed6694695ac89f9a8d49c07 (patch)
tree6d052a72fae3a5238598e38ec05a3fcc6e7b165a /Makefile.am
parent9d3707a78f8adb5851ff65dbc4254d628556b03b (diff)
build: Only build the assembler if flex and bison are found
And start displaying a nice summary of what we are going to compile. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a8062329..67b6563f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,11 @@
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS} -I m4
-SUBDIRS = lib man tools scripts benchmarks demos assembler
+SUBDIRS = lib man tools scripts benchmarks demos
+
+if BUILD_ASSEMBLER
+SUBDIRS += assembler
+endif
if BUILD_SHADER_DEBUGGER
SUBDIRS += debugger