summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2016-01-25 18:33:12 +0000
committerDaniel Stone <daniels@collabora.com>2016-01-25 19:53:36 +0000
commitbccc0ec6a3fdae880e14770c2ff5770fb86ea6fc (patch)
tree3b60d2bea6e9788877da80bdddfd0633f0e5c64d /Makefile.am
parente6ca4bd7cd911c2a422fd6961970fc5df2b071a0 (diff)
build: Disable x86-specific utilities on non-x86
Some bits can't be built on non-x86 architectures, mostly because they require x86-specific assembly primitives. Disable these by default on non-x86 architectures. Signed-off-by: Daniel Stone <daniels@collabora.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f71a3a6..60168628 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,8 +21,13 @@
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS} -I m4
-SUBDIRS = lib man tools scripts benchmarks demos overlay
+SUBDIRS = lib man tools scripts benchmarks
+if BUILD_TESTS
+SUBDIRS += tests
+endif
+
+if BUILD_X86
if BUILD_ASSEMBLER
SUBDIRS += assembler
endif
@@ -31,8 +36,7 @@ if BUILD_SHADER_DEBUGGER
SUBDIRS += debugger
endif
-if BUILD_TESTS
-SUBDIRS += tests
+SUBDIRS += overlay demos benchmarks
endif
SUBDIRS += docs