summaryrefslogtreecommitdiff
path: root/assembler/meson.build
diff options
context:
space:
mode:
authorAdam Sampson <ats@offog.org>2018-04-03 23:48:44 +0100
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-04-04 16:43:27 +0300
commit0e143039fd190f1d22d03f9617af69af3c48b076 (patch)
tree836d4c34507c1b45baa9da4e9e6051b24f630f1e /assembler/meson.build
parent2440f7220f6416156f3daf24dd073be396a44dcd (diff)
Test that register types are accepted in all valid forms.
The assembler should accept ub, :ub, UB and :UB. Signed-off-by: Adam Sampson <ats@offog.org> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'assembler/meson.build')
-rw-r--r--assembler/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/assembler/meson.build b/assembler/meson.build
index c858bc0f..cefdba93 100644
--- a/assembler/meson.build
+++ b/assembler/meson.build
@@ -47,6 +47,7 @@ configure_file(input : 'intel-gen4asm.pc.in', output : 'intel-gen4asm.pc',
gen4asm_testcases = [
'test/mov',
'test/frc',
+ 'test/regtype',
'test/rndd',
'test/rndu',
'test/rnde',