summaryrefslogtreecommitdiff
path: root/benchmarks/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-08-09 17:39:41 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2015-08-09 19:20:46 +0100
commit0393e7288ba3a640fcc9f0d8b15d7dee231a039c (patch)
treeba71ce2562d70ee523863aa8dd134853e5b1d4eb /benchmarks/Makefile.am
parent74a806808618dad614d7ffb61d4562915695bbf8 (diff)
benchmarks: Record and replay calls to EXECBUFFER2
This slightly idealises the behaviour of clients with the aim of measuring the kernel overhead of different workloads. This test focuses on the cost of relocating batchbuffers. A trace file is generated with an LD_PRELOAD intercept around execbuffer, which we can then replay at our leisure. The replay replaces the real buffers with a set of empty ones so the only thing that the kernel has to do is parse the relocations. but without a real workload we lose the impact of having to rewrite active buffers. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'benchmarks/Makefile.am')
-rw-r--r--benchmarks/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/benchmarks/Makefile.am b/benchmarks/Makefile.am
index e042dd17..5bacd52e 100644
--- a/benchmarks/Makefile.am
+++ b/benchmarks/Makefile.am
@@ -4,3 +4,7 @@ include Makefile.sources
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS)
LDADD = $(top_builddir)/lib/libintel_tools.la $(DRM_LIBS) $(PCIACCESS_LIBS) $(CAIRO_LIBS) $(LIBUNWIND_LIBS) -lm
+
+noinst_LTLIBRARIES = generate_trace.la
+generate_trace_la_LDFLAGS = -module -avoid-version -no-undefined
+generate_trace_la_LIBADD = -ldl