summaryrefslogtreecommitdiff
path: root/benchmarks/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2016-03-09 22:39:16 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2016-03-09 23:40:21 +0000
commit6cd15fb930793f441eaa829bd087ac34e644e492 (patch)
tree5c5142c30ac87cc19a724487a9267074ba82b04c /benchmarks/Makefile.am
parent0aacdac56fc3179b1fe6bc28bb1a3beb64c64619 (diff)
benchmarks: Add gem_syslatency
Instead of measuring the wakeup latency of a GEM client, we turn the tables here and ask what is the wakeup latency of a normal process competing with GEM. In particular, a realtime process that expects deterministic latency. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'benchmarks/Makefile.am')
-rw-r--r--benchmarks/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/benchmarks/Makefile.am b/benchmarks/Makefile.am
index c31bec58..a555ab6a 100644
--- a/benchmarks/Makefile.am
+++ b/benchmarks/Makefile.am
@@ -11,5 +11,7 @@ gem_exec_tracer_la_LIBADD = -ldl
gem_latency_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_latency_LDADD = $(LDADD) -lpthread
+gem_syslatency_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
+gem_syslatency_LDADD = $(LDADD) -lpthread -lrt
EXTRA_DIST=README