summaryrefslogtreecommitdiff
path: root/benchmarks/Makefile.am
diff options
context:
space:
mode:
authormarius vlad <marius.c.vlad@intel.com>2016-05-10 17:32:15 +0300
committerMarius Vlad <marius.c.vlad@intel.com>2016-05-11 18:22:05 +0300
commit701d8fdb363443453c4b613e9180f75ad36a7321 (patch)
tree200be95af16c037a99807fadcd764f736db482c1 /benchmarks/Makefile.am
parent2d432fc5773df17f04283f4780dab161dd2e1c85 (diff)
benchmarks/, overlay/, demos/, tools/, tests/: Add optional Werror.
v2: Initially added Werror by default. Make it optional so it doesn't break android build and (potential) distros maintaing the package (Hinted by Damien Lespiau). --enable-werror will enable -Werror compiler flag. Signed-off-by: Marius Vlad <marius.c.vlad@intel.com> Acked-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'benchmarks/Makefile.am')
-rw-r--r--benchmarks/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/benchmarks/Makefile.am b/benchmarks/Makefile.am
index 2c2d1006..49d2f649 100644
--- a/benchmarks/Makefile.am
+++ b/benchmarks/Makefile.am
@@ -2,7 +2,8 @@
include Makefile.sources
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
-AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS)
+AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS) \
+ $(WERROR_CFLAGS)
LDADD = $(top_builddir)/lib/libintel_tools.la
benchmarks_LTLIBRARIES = gem_exec_tracer.la