summaryrefslogtreecommitdiff
path: root/benchmarks/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2017-11-10 12:49:14 -0800
committerEric Anholt <eric@anholt.net>2017-11-21 09:52:57 -0800
commitaa97faa3828488478d97c1fce51650591681bdc9 (patch)
tree3d56dda9b811413245d59fab786736af8e9ffb53 /benchmarks/Makefile.am
parent53efeac5b9b67c35483ee2e5db6fdfc1665de12f (diff)
lib: Use drm-uapi/i915_drm.h instead of local defines.
The MMAP_V2 is replaced by just using MMAP, since the official header has the updated struct. The gem_create_v2 and gem_get_aperture are left as is, because they seem to not be reflected in the UABI header! Signed-off-by: Eric Anholt <eric@anholt.net> Acked-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'benchmarks/Makefile.am')
-rw-r--r--benchmarks/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/benchmarks/Makefile.am b/benchmarks/Makefile.am
index d066112a..9f2671be 100644
--- a/benchmarks/Makefile.am
+++ b/benchmarks/Makefile.am
@@ -8,7 +8,11 @@ if HAVE_LIBDRM_INTEL
benchmarks_PROGRAMS += $(LIBDRM_INTEL_BENCHMARKS)
endif
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/include/drm-uapi \
+ -I$(top_srcdir)/lib
+
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS) \
$(WERROR_CFLAGS) -D_GNU_SOURCE
LDADD = $(top_builddir)/lib/libintel_tools.la