summaryrefslogtreecommitdiff
path: root/benchmarks/Makefile.am
diff options
context:
space:
mode:
authorRobert Foss <robert.foss@collabora.com>2016-07-27 13:17:38 -0400
committerDaniel Vetter <daniel.vetter@ffwll.ch>2016-08-04 13:13:05 +0200
commitf6b9f961aaca1a255e833564a7d50a079d9e51b2 (patch)
tree3d6cffd7e768f0205732728eb5fd03e26ee05d5c /benchmarks/Makefile.am
parent8680b48ac85abacb9114a9cd98c72cb47f750e89 (diff)
benchmarks/Makefile: Don't build benchmarks that depend on libdrm_intel
Use the HAS_INTEL automake flag to avoid building benchmarks that won't compile unless libdrm_intel is available in the build system. Signed-off-by: Robert Foss <robert.foss@collabora.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'benchmarks/Makefile.am')
-rw-r--r--benchmarks/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/benchmarks/Makefile.am b/benchmarks/Makefile.am
index 49d2f649..7400dd0f 100644
--- a/benchmarks/Makefile.am
+++ b/benchmarks/Makefile.am
@@ -1,6 +1,9 @@
-
include Makefile.sources
+if HAVE_LIBDRM_INTEL
+ benchmarks_PROGRAMS += $(LIBDRM_INTEL_BENCHMARKS)
+endif
+
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS) \
$(WERROR_CFLAGS)