summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Widawsky <ben@bwidawsk.net>2011-10-31 13:36:50 -0700
committerBen Widawsky <ben@bwidawsk.net>2011-10-31 17:34:16 -0700
commit15830ea54be914b1f4005154b2dcba52fa6b6120 (patch)
tree0df8cf67ee927e2b1b4aa07b653cb72776950217 /configure.ac
parent32910231514d938be269c3b087f0d444709b0466 (diff)
i-g-t/debugger: Only allow the shader debugger if the user has specified a gen4asm
Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4629decf..92b2372f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,7 +93,12 @@ AC_ARG_ENABLE(shader-debugger,
[SHADER_DEBUGGER=no])
AM_CONDITIONAL(HAVE_SHADER_DEBUGGER, [test "x$SHADER_DEBUGGER" = xyes])
if test "x$SHADER_DEBUGGER" = xyes; then
- AC_DEFINE(HAVE_SHADER_DEBUGGER, 1, [Have shader debugging support])
+ AC_CHECK_PROG([GEN4ASM], intel-gen4asm, intel-gen4asm)
+ if test -z "$GEN4ASM"; then
+ AC_MSG_ERROR([Cannot find intel-gen4asm in your path; please set GEN4ASM env variable])
+ else
+ AC_DEFINE(HAVE_SHADER_DEBUGGER, 1, [Have shader debugging support])
+ fi
fi
m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])