summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLyude <lyude@redhat.com>2016-12-21 14:00:54 -0500
committerLyude <lyude@redhat.com>2017-01-03 13:56:22 -0500
commit31811f4b6c5a95de82e47ddf1f37739c3b2cfc58 (patch)
tree45740db84fce7d3739d49878e48387311b7c29bb /configure.ac
parentc7c581a6843644343c15e964eddacab4a6c77769 (diff)
igt_core: add igt_constructor
This is a simple macro for executing a block of code at the beginning of intel-gpu-tools, before any tests have been ran. Useful for initialization of global resources used in IGT libraries. Signed-off-by: Lyude <lyude@redhat.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk> Changes since v1: - Add the line number into the name of the constructor function so that multiple constructors may be used per-file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fa31a52e..411bfabf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,7 @@ AC_CHECK_TYPES([sighandler_t],[],[],[AC_INCLUDES_DEFAULT
#include <signal.h>])
AC_CHECK_FUNCS([swapctl])
AC_CHECK_FUNCS([asprintf])
+AX_GCC_FUNC_ATTRIBUTE([constructor])
dnl Check for POSIX timers
AC_CHECK_FUNCS(timer_create, [], [