summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2017-04-22 13:45:18 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2017-04-22 18:22:22 +0100
commit36b92e809f378e18af980ffa5b29361bd28098cb (patch)
treef5522791e7d66ada6d091f5f1ba1a37467e82127 /configure.ac
parent009a35e878c66e38d3f4b980f6cdb995d2662533 (diff)
igt: Import basic amdgpu tests from libdrm
Simple copy and replace of the CUnit tests inside libdrm to form a basis for further prime integration testing. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 12b0ab0e..5342e33c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,6 +203,18 @@ AC_SUBST([DRM_LIBS])
AM_CONDITIONAL(HAVE_LIBDRM_INTEL, [test "x$INTEL" = xyes])
+AC_ARG_ENABLE(amdgpu, AS_HELP_STRING([--disable-amdgpu],
+ [Enable building of amdgpu tests (default: auto)]),
+ [AMDGPU=$enableval], [AMDGPU=auto])
+if test "x$AMDGPU" = xauto; then
+ PKG_CHECK_EXISTS([libdrm_amdgpu], [AMDGPU=yes], [AMDGPU=no])
+fi
+if test "x$AMDGPU" = xyes; then
+ PKG_CHECK_MODULES(DRM_AMDGPU, [libdrm_amdgpu])
+ AC_DEFINE(HAVE_LIBDRM_AMDGPU, 1, [Have amdgpu support])
+fi
+AM_CONDITIONAL(HAVE_LIBDRM_AMDGPU, [test "x$AMDGPU" = xyes])
+
# for dma-buf tests
AC_ARG_ENABLE(nouveau, AS_HELP_STRING([--disable-nouveau],
[Enable use of nouveau API for prime tests (default: auto)]),