summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Kocialkowski <paul.kocialkowski@linux.intel.com>2017-08-21 18:27:20 +0300
committerLyude <lyude@redhat.com>2017-08-21 13:54:01 -0400
commit4524a8951348a31ae5dabfc4c69f2a835034ec3e (patch)
tree7d816a66f21c686e0d8f335687d491ebdd46fb9e /configure.ac
parent1579692d6447d126552b5fb020a63b26427c9a12 (diff)
tests: Introduce audio tests, starting with HDMI signal integrity
This introduces a new test for audio going through display connectors. It currently contains a single subtest for HDMI signal integrity, but other test cases will be added later on. The test setup consists in using an HDMI-VGA bridge that separates the audio out (via a 3.5 mm jack) and feeding this back to the DUT's line-in where it can be recorded by ALSA with controls correctly configured. The audio test makes use of the audio and ALSA igt libraries helpers. Signed-off-by: Paul Kocialkowski <paul.kocialkowski@linux.intel.com> Reviewed-by: Lyude Paul <lyude@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e66273a4..41ec4d26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,6 +222,23 @@ fi
PKG_CHECK_MODULES(ALSA, [alsa], [alsa=yes], [alsa=no])
AM_CONDITIONAL(HAVE_ALSA, [test "x$alsa" = xyes])
+# for audio
+AC_ARG_ENABLE(audio, AS_HELP_STRING([--enable-audio],
+ [Enable building of audio tests (default: no)]),
+ [if test x$enableval = xyes; then enable_audio=yes; fi],
+ [enable_audio=no])
+AM_CONDITIONAL(HAVE_AUDIO, [test "x$enable_audio" = xyes])
+if test "x$enable_audio" = xyes; then
+ if test x"$alsa" != xyes; then
+ AC_MSG_ERROR([Failed to find ALSA, required by audio.])
+ fi
+ if test x"$gsl" != xyes; then
+ AC_MSG_ERROR([Failed to find gsl, required by audio.])
+ fi
+
+ AC_DEFINE(HAVE_AUDIO, 1, [Enable Audio support])
+fi
+
# -----------------------------------------------------------------------------
# Configuration options
# -----------------------------------------------------------------------------
@@ -420,6 +437,7 @@ echo ""
echo " • Tests:"
echo " Build tests : ${BUILD_TESTS}"
echo " Chamelium tests : ${enable_chamelium}"
+echo " Audio tests : ${enable_audio}"
echo " Compile prime tests: ${NOUVEAU}"
echo " Print stack traces : ${with_libunwind}"
echo " Debug flags : ${DEBUG_CFLAGS}"