summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2013-01-21 23:02:36 +0000
committerDamien Lespiau <damien.lespiau@intel.com>2013-03-04 15:54:35 +0000
commit5435708a50beb0368ed6694695ac89f9a8d49c07 (patch)
tree6d052a72fae3a5238598e38ec05a3fcc6e7b165a /configure.ac
parent9d3707a78f8adb5851ff65dbc4254d628556b03b (diff)
build: Only build the assembler if flex and bison are found
And start displaying a nice summary of what we are going to compile. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38ed3e69..c392812b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,12 @@ if test x"$udev" = xyes; then
fi
PKG_CHECK_MODULES(GLIB, glib-2.0)
+# can we build the assembler?
+AS_IF([test x"$LEX" != "x:" -a x"$YACC" != xyacc],
+ [enable_assembler=yes],
+ [enable_assembler=no])
+AM_CONDITIONAL(BUILD_ASSEMBLER, [test "x$enable_assembler" = xyes])
+
# -----------------------------------------------------------------------------
# Configuration options
# -----------------------------------------------------------------------------
@@ -178,4 +184,13 @@ AC_CONFIG_FILES([
])
AC_OUTPUT
+# Print a summary of the compilation
+echo ""
+echo "Intel GPU tools"
+
+echo ""
+echo " • Tools:"
+echo " Assembler: ${enable_assembler}"
+echo ""
+
# vim: set ft=config ts=8 sw=8 tw=0 noet :