summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2017-07-04 16:28:58 +0300
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2017-07-06 14:02:48 +0300
commit8cb5656fd46d4b4d96b85b487a15f6d9c436b104 (patch)
tree1179c257b78cd18f70297df787dc632ca32a2265 /configure.ac
parent437e0c6c17697715eb2058632beeeff0327c5f9d (diff)
configure.ac: Make AMDGPU depend on libdrm >= 2.4.76
AMDGPU_FAMILY_AI was introduced in commit being part of libdrm 2.4.76 release and amd_basic tests are using that define. Since the module is turned on by default this results in compilation failing on machines with older libdrm. Let make them fail on ./configure step instead. Cc: Leo Liu <leo.liu@amd.com> Cc: Chris Wilson <chris@chris-wilson.co.uk> Reported-by: Martin Peres <martin.peres@intel.com> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0418e605..bf09927c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,7 +217,7 @@ if test "x$AMDGPU" = xauto; then
PKG_CHECK_EXISTS([libdrm_amdgpu], [AMDGPU=yes], [AMDGPU=no])
fi
if test "x$AMDGPU" = xyes; then
- PKG_CHECK_MODULES(DRM_AMDGPU, [libdrm_amdgpu])
+ PKG_CHECK_MODULES(DRM_AMDGPU, [libdrm_amdgpu >= 2.4.76])
AC_DEFINE(HAVE_LIBDRM_AMDGPU, 1, [Have amdgpu support])
fi
AM_CONDITIONAL(HAVE_LIBDRM_AMDGPU, [test "x$AMDGPU" = xyes])