summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNavare, Manasi D <manasi.d.navare@intel.com>2017-01-23 18:48:53 -0800
committerPetri Latvala <petri.latvala@intel.com>2017-01-25 12:32:17 +0200
commit9f3369750ca82e952018276b80e196908795ee74 (patch)
tree8beed35ae9435055a52c670313fdaa88ffb617b9 /configure.ac
parentfa45f588b78cc19896859abd1cffc23847370769 (diff)
tools: Add intel_dp_compliance for DisplayPort 1.2 compliance automation
This is the userspace component of the Displayport Compliance testing software required for compliance testing of the I915 Display Port driver. This must be running in order to successfully complete Display Port compliance testing. This app and the kernel code that accompanies it has been written to satify the requirements of the Displayport Link CTS 1.2 rev1.1 specification from VESA. Note that this application does not support eDP compliance testing. This utility has an automation support for the Link training tests (4.3.1.1. - 4.3.2.3), EDID tests (4.2.2.3 - 4.2.2.6) and Video Pattern generation tests (4.3.3.1) from CTS specification 1.2 Rev 1.1. This tool has the support for responding to the hotplug uevents sent by compliance testting unit after each test. The Linux DUT running this utility must be in text (console) mode and cannot have any other display manager running. Since this uses sysfs nodes for kernel interaction, this utility should be run as Root. Once this user application is up and running, waiting for test requests, the test appliance software on the windows host can now be used to execute the compliance tests. This app is based on some prior work done in April 2015 (by Todd Previte <tprevite@gmail.com>) v2: * Add mode unset on hotplug uevent on disconnect (Manasi Navare) v3: Made capitalization consistent Reduced line lengths Added return value checks Changed how GLib is linked Fixed build warnings v4: * Conditionally build this tool if UDEV is present (Petri Latvala) * igt_warn and info cleanup to remove \r * Add intel_dp_compliance to tools/.gitignore * Change the year in copyright statements to current (Petri Latvala) Cc: Petri Latvala <petri.latvala@intel.com> Cc: Marius Vlad <marius.c.vlad@intel.com> Cc: Daniel Vetter <daniel.vetter@ffwll.ch> Signed-off-by: Manasi Navare <manasi.d.navare@intel.com> Signed-off-by: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 411bfabf..d2681400 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,6 +164,7 @@ PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3, AC_DEFINE(HAVE_XRANDR, 1, [Have libXran
# for testdisplay
PKG_CHECK_MODULES(CAIRO, [cairo >= 1.12.0])
PKG_CHECK_MODULES(LIBUDEV, [libudev], [udev=yes], [udev=no])
+AM_CONDITIONAL(HAVE_UDEV, [test "x$udev" = xyes])
if test x"$udev" = xyes; then
AC_DEFINE(HAVE_UDEV,1,[Enable udev-based monitor hotplug detection])
fi