summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2019-02-28 14:06:26 +0000
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2019-03-04 07:01:09 +0000
commita117a5b819a76894fcee02a7cc134aa2b1249c78 (patch)
tree2c847628e24959105d8260469ad0a7a68dc8ee0d /configure.ac
parent27027cf078e5e8c4ced3b7d941890659e4adf1cd (diff)
autoconf: Silence void pointer arithmetic warnings
Meson build does it so make the two symmetrical in this respect. v2: * Do it properly. (Chris Wilson) Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f55ea5d..e22703d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,6 +256,9 @@ AC_ARG_ENABLE(werror,
[Fail on warnings]),
[], [enable_werror=no])
+# disable "warning: pointer of type ‘void *’ used in arithmetic"
+AS_COMPILER_FLAG([-Wno-pointer-arith], [CWARNFLAGS+=" -Wno-pointer-arith"], [])
+
if test "x$enable_debug" = xyes; then
AS_COMPILER_FLAG([-g3], [DEBUG_CFLAGS="-g3"], [DEBUG_CFLAGS="-g"])
AS_COMPILER_FLAG([-Og], [DEBUG_CFLAGS+=" -Og -Wno-maybe-uninitialized"], # disable maybe-uninitialized due to false positives