summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Widawsky <benjamin.widawsky@intel.com>2013-10-05 16:21:11 -0700
committerBen Widawsky <benjamin.widawsky@intel.com>2013-10-05 16:21:11 -0700
commitbc888c2b42ab42d628d9c11181a5ba09df66fdcc (patch)
tree857c6ad15793abed97477ef9eee89e64375547f1 /configure.ac
parentae599546fadb3b8ebc3114f8ab5b58cffc467952 (diff)
configure.ac: require dri2proto for overlay
With the introduction of commit f9a50de3dcc501e930de6c60983a4feb57121e7e Author: Chris Wilson <chris@chris-wilson.co.uk> Date: Sat Aug 17 11:12:07 2013 +0100 Introduce intel-gpu-overlay dri2proto became a dependency (and there is no way to disable overlay explicitly. The actual version chosen was arbitrarily stolen from mesa. Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d5c65c24..741dd749 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,9 +80,11 @@ AM_CONDITIONAL(BUILD_OVERLAY_XLIB, [test "x$enable_overlay_xlib" = xyes])
AM_CONDITIONAL(BUILD_OVERLAY, [test "x$enable_overlay_xlib" = xyes -o "x$enable_overlay_xvlib"])
if test x$enable_overlay_xvlib = xyes; then
AC_DEFINE(HAVE_OVERLAY_XVLIB, 1, [Enable XV backend])
+ PKG_CHECK_MODULES(DRI2PROTO, [dri2proto >= 2.6])
fi
if test x$enable_overlay_xlib = xyes; then
AC_DEFINE(HAVE_OVERLAY_XLIB, 1, [Enable X backend])
+ PKG_CHECK_MODULES(DRI2PROTO, [dri2proto >= 2.6])
fi
PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3, AC_DEFINE(HAVE_XRANDR, 1, [Have libXrandr]), [have_xrandr=no])