summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Kocialkowski <paul.kocialkowski@linux.intel.com>2017-07-25 15:48:23 +0300
committerLyude <lyude@redhat.com>2017-07-25 12:55:59 -0400
commitcae92705b68eacc17f9fbc11b840d92ca9b7888e (patch)
tree08b33b7df6af9b562575ed53b4a9918f43f35aa5 /configure.ac
parentbbb0dbb04f5564a9d1e6401855ddba608ea1ae4a (diff)
configure.ac: Make udev a dependency for chamelium
Chamelium testing has a hard dependency on udev. This makes this dependency explicit in configure instead of failing the build when it is missing. Signed-off-by: Paul Kocialkowski <paul.kocialkowski@linux.intel.com> Reviewed-by: Lyude <lyude@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dec3e923..a6ab9e4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,9 @@ if test "x$enable_chamelium" = xyes; then
[AC_MSG_ERROR([Failed to find xmlrpc, required by chamelium. Use --disable-chamelium to disable chamelium support.])])
PKG_CHECK_MODULES(PIXMAN, pixman-1, [],
[AC_MSG_ERROR([Failed to find pixman, required by chamelium. Use --disable-chamelium to disable chamelium support.])])
+ if test x"$udev" != xyes; then
+ AC_MSG_ERROR([Failed to find udev, required by chamelium. Use --disable-chamelium to disable chamelium support.])
+ fi
if test x"$glib" != xyes; then
AC_MSG_ERROR([Failed to find glib, required by chamelium. Use --disable-chamelium to disable chamelium support.])
fi