summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2017-11-10 12:39:56 -0800
committerEric Anholt <eric@anholt.net>2017-11-21 09:52:52 -0800
commitd21e95ca81da6f9332999ceebe6b42e4425d3bb6 (patch)
treeec5ea9f9fb7aba73bbed7836be9d7668e3a45b6b /configure.ac
parent4eb53c7cc02a36a23c33f786cb20bf078719f40e (diff)
tests: Remove libdrm_vc4 dependency.
The autotools build retains the configure.ac option, while meson folds vc4 into the default build since we don't have any meson_options.txt to control parts of the build. Signed-off-by: Eric Anholt <eric@anholt.net> Acked-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 53ef704e..adb59981 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,16 +288,12 @@ fi
AM_CONDITIONAL(HAVE_LIBDRM_NOUVEAU, [test "x$NOUVEAU" = xyes])
AC_ARG_ENABLE(vc4, AS_HELP_STRING([--disable-vc4],
- [Enable building of vc4 tests (default: auto)]),
- [VC4=$enableval], [VC4=auto])
-if test "x$VC4" = xauto; then
- PKG_CHECK_EXISTS([libdrm_vc4], [VC4=yes], [VC4=no])
-fi
+ [Enable building of vc4 tests (default: yes)]),
+ [VC4=$enableval], [VC4=yes])
if test "x$VC4" = xyes; then
- PKG_CHECK_MODULES(DRM_VC4, [libdrm_vc4])
- AC_DEFINE(HAVE_LIBDRM_VC4, 1, [Have vc4 support])
+ AC_DEFINE(BUILD_VC4, 1, [Have vc4 support])
fi
-AM_CONDITIONAL(HAVE_LIBDRM_VC4, [test "x$VC4" = xyes])
+AM_CONDITIONAL(BUILD_VC4, [test "x$VC4" = xyes])
# Define a configure option for the shader debugger
AC_ARG_ENABLE(shader-debugger, AS_HELP_STRING([--enable-shader-debugger],