summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@bootlin.com>2018-10-04 14:39:01 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-10-08 16:54:06 +0300
commitddb382855e25cd0fd81c56f75f380d4c4422fbad (patch)
treeebd4479f475f236820ce1ccc3717373680634767 /configure.ac
parente3b1c3498abf54377245e6d298b4cbcef663d8b4 (diff)
igt: Make pixman mandatory
So far, pixman was used exclusively when the Chamelium support was enabled. However, since we're going to use it as one of the backend to do the igt_fb conversions between formats, we'll need it all the time. Make that explicit. Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c75ef284..b80e905e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,6 +183,7 @@ PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3, AC_DEFINE(HAVE_XRANDR, 1, [Have libXran
PKG_CHECK_MODULES(CAIRO, [cairo >= 1.12.0])
PKG_CHECK_MODULES(LIBUDEV, [libudev])
PKG_CHECK_MODULES(GLIB, [glib-2.0])
+PKG_CHECK_MODULES(PIXMAN, [pixman-1])
PKG_CHECK_MODULES(GSL, [gsl], [gsl=yes], [gsl=no])
AM_CONDITIONAL(HAVE_GSL, [test "x$gsl" = xyes])
@@ -206,8 +207,6 @@ if test "x$enable_chamelium" = xyes; then
AC_MSG_ERROR([Failed to find xmlrpc, required by chamelium.])
fi
fi
- PKG_CHECK_MODULES(PIXMAN, pixman-1, [],
- [AC_MSG_ERROR([Failed to find pixman, required by chamelium.])])
if test x"$gsl" != xyes; then
AC_MSG_ERROR([Failed to find gsl, required by chamelium.])
fi