summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Kocialkowski <paul.kocialkowski@linux.intel.com>2017-07-20 18:13:37 +0300
committerLyude <lyude@redhat.com>2017-07-20 13:13:05 -0400
commite246ff0d507a7fb1ddc8a839205f030ed44c21e5 (patch)
tree15480401b5ab5cce8fe3ba6a7af310294940c356 /configure.ac
parent8cf32fe06c8f54bca11c485ccc1cc3899f9d81db (diff)
chamelium: Add support for VGA frame comparison testing
This adds support for VGA frame comparison testing with the reference generated from cairo. The retrieved frame from the chamelium is first cropped, as it contains the blanking intervals, through a dedicated helper. Another helper function asserts that the analog frame matches or dump it to png if not. Signed-off-by: Paul Kocialkowski <paul.kocialkowski@linux.intel.com> Reviewed-by: Lyude <lyude@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ea768e2..dec3e923 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,10 @@ if test "x$enable_chamelium" = xyes; then
if test x"$glib" != xyes; then
AC_MSG_ERROR([Failed to find glib, required by chamelium. Use --disable-chamelium to disable chamelium support.])
fi
+ if test x"$gsl" != xyes; then
+ AC_MSG_ERROR([Failed to find gsl, required by chamelium. Use --disable-chamelium to disable chamelium support.])
+ fi
+
AC_DEFINE(HAVE_CHAMELIUM, 1, [Enable Chamelium support])
fi