summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <kristian.h.kristensen@intel.com>2015-07-29 23:12:16 -0700
committerKristian Høgsberg Kristensen <kristian.h.kristensen@intel.com>2015-07-31 10:40:04 -0700
commite6a5d799fcdba567535a434789e107164072c15b (patch)
tree83512c5ea2a393d3a692a61919cfc8212a4131bb /configure.ac
parent6bd42ce9c74f2b6d27b0263191295de232050ab5 (diff)
tools: Add LD_PRELOAD-based AUB dumper tool
This does everything the aub dump functionality in libdrm does, but without being part of libdrm. This moves the very developer oriented functionality out of core libdrm and adds some flexibility in how we activate it (we can specify filename, for example). Most importantly, this lets us dump aub files for tools and/or drivers that don't use libdrm, without having to add that code to each of those projects. The tool is used much like strace or valgrind. For example: $ intel_aubdump -v --output=stuff.aub -- glxgears -geometry 500x500 will launch glxgears with its options and enable aub dumping and pass the -v and --output=stuff.aub options to the aub dumper. Signed-off-by: Kristian Høgsberg Kristensen <kristian.h.kristensen@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3770b2fc..6fc63e4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,7 @@ AC_CONFIG_FILES([
scripts/Makefile
tests/Makefile
tools/Makefile
+ tools/intel_aubdump
tools/quick_dump/Makefile
tools/null_state_gen/Makefile
debugger/Makefile
@@ -264,7 +265,9 @@ AC_CONFIG_FILES([
assembler/test/Makefile
assembler/intel-gen4asm.pc
overlay/Makefile
- ])
+ ],
+ [chmod +x tools/intel_aubdump])
+
AC_OUTPUT
# Print a summary of the compilation