summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2015-07-02 14:59:25 +0100
committerDamien Lespiau <damien.lespiau@intel.com>2015-07-02 15:23:35 +0100
commitec9e5996d1c54d71c1c9cd14755ec6eddfdb0680 (patch)
tree816c0404dc6d7540f2d7eae27891528c2f66ef5d /configure.ac
parent64295c67e908d59606fafe35e2d2363802c7faec (diff)
build: Don't use automake's conditional in a Makefile.sources
I just remembered that those Makefile.sources files where also included by the Android build system, so we can't use automake's conditionals in there. So, we want to use GNU make's one. Unfortunately, after all those years, GNU automake still doesn't do anything useful with GNU make's ifeq: lib/Makefile.sources:66: error: else without if automake will helpfully signal that the 'else' corresponding to the 'ifeq' doesn't have a corresponding 'if'. Well, yeah, thanks. Fortunately, we can work around this by cunningly inserting a space before 'ifeq', 'else' and 'endif' and fool automake's regex-based checks. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a69a3815..77b595b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,7 +217,7 @@ AC_ARG_ENABLE(git-hash,
AS_HELP_STRING([--disable-git-hash],
[Do not use git hash in version]),
[git_hash=$enableval], [git_hash=yes])
-AM_CONDITIONAL(SKIP_GIT_HASH, [test "x$git_hash" = xno])
+AC_SUBST(GIT_HASH, [$git_hash])
# -----------------------------------------------------------------------------