summaryrefslogtreecommitdiff
path: root/docs/reference/intel-gpu-tools/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2014-11-19 15:44:00 +0000
committerThomas Wood <thomas.wood@intel.com>2014-12-04 16:07:55 +0000
commita5425a101cd38941961c13f97b56aa0683f64f8e (patch)
tree8f5453ae0a5753bdab1846cac1e7016618583bc9 /docs/reference/intel-gpu-tools/Makefile.am
parentbc6dc7efdb65a6f5ac01cc2c306951dd9dd92fc4 (diff)
docs: add a glossary of test name terms
Add a glossary of test name terms based on the details in tests/NAMING-CONVENTION. Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'docs/reference/intel-gpu-tools/Makefile.am')
-rw-r--r--docs/reference/intel-gpu-tools/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/docs/reference/intel-gpu-tools/Makefile.am b/docs/reference/intel-gpu-tools/Makefile.am
index d7ef4dfc..b40680bd 100644
--- a/docs/reference/intel-gpu-tools/Makefile.am
+++ b/docs/reference/intel-gpu-tools/Makefile.am
@@ -1,6 +1,8 @@
## Process this file with automake to produce Makefile.in
TESTLISTS = $(top_builddir)/tests/single-tests.txt $(top_builddir)/tests/multi-tests.txt
+KEYWORDS = (hang|swap|thrash|crc|tiled|tiling|rte|ctx|exec|rpm)
+
xml/igt_test_programs_%_programs.xml: $(TESTLISTS)
mkdir -p `dirname $@`
echo "<?xml version=\"1.0\"?>" > $@
@@ -32,7 +34,9 @@ xml/igt_test_programs_%_description.xml: $(TESTLISTS)
echo "<refsect1>" >> $@
echo "<title>Description</title>" >> $@
for test in `cat $(TESTLISTS) | tr ' ' '\n' | grep "^$*" | sort`; do \
- echo "<refsect2 id=\"$$test\"><title>$$test</title><para>" >> $@; \
+ echo "<refsect2 id=\"$$test\"><title>" >> $@; \
+ echo "$$test" | perl -pe 's/(?<=_)$(KEYWORDS)(?=(_|\W))/<acronym>\1<\/acronym>/g' >> $@; \
+ echo "</title><para>" >> $@; \
if [ -x $(top_builddir)/tests/$$test ]; then \
testprog=$(top_builddir)/tests/$$test; \
else \
@@ -44,7 +48,9 @@ xml/igt_test_programs_%_description.xml: $(TESTLISTS)
echo "<refsect3><title>Subtests</title>" >> $@; \
echo "<simplelist>" >> $@; \
for subtest in `./$$testprog --list-subtests`; do \
- echo "<member>$$subtest</member>" >> $@; \
+ echo "<member>" >> $@; \
+ echo "$$subtest" | perl -pe 's/\b$(KEYWORDS)\b/<acronym>\1<\/acronym>/g' >> $@; \
+ echo "</member>" >> $@; \
done; \
echo "</simplelist></refsect3>" >> $@; \
fi; \