summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2019-01-31 14:21:35 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2019-03-26 10:12:55 +0000
commit25fcb1c23dc5318b103d6c096b2dcfaea98dad3d (patch)
tree3909344687b76641d9ce7e9fc84d774b70f9c0a8 /lib/Makefile.am
parenta4dc3d0f9ac6abf2a0ca6a4771255cb5dcb3b07b (diff)
lib: Add GPU power measurement
Read the RAPL power metrics courtesy of perf. Or your local HW equivalent? v2: uselocale() v3: Use gpu_power_s(), gpu_power_J(), gpu_power_W() to try and make the scale factors self-consistent. v4: Use igt_sysfs v5: s/tN/sampleN/ Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3e6a7fdb..62e8bda7 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -84,4 +84,5 @@ libintel_tools_la_LIBADD = \
$(LIBUDEV_LIBS) \
$(PIXMAN_LIBS) \
$(GLIB_LIBS) \
+ libigt_perf.la \
-lm