summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTim Gore <tim.gore@intel.com>2014-07-24 17:38:22 +0100
committerThomas Wood <thomas.wood@intel.com>2014-07-25 14:46:51 +0100
commit57bd86068a319b218796d0bea92258b44ee143a0 (patch)
treec37f9322d2f0432671f1556271bcf51fc4eacad0 /lib/Makefile.am
parent8408e00e623b52f18ad0795122593741197fa2f4 (diff)
intel-gpu-tools: fix version.h creation in android
commit 743dc7997aa9f5210055896940d87c88983dcda6 breaks the build under Android because version.h is not created. This happens because the android make executes from the ANDROID_BUILD_TOP directory rather than from the directory containing the source files, so we need to differentiate between Android and linux builds. This is V2 of this patch based on Thomas Wood's suggestion. Signed-off-by: Tim Gore <tim.gore@intel.com> [Thomas: Fix distcheck issues] Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 4d4efe48..e8e04a25 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,3 +1,6 @@
+IGT_LIB_PATH := $(builddir)
+GPU_TOOLS_PATH := $(top_srcdir)
+
include Makefile.sources
noinst_LTLIBRARIES = libintel_tools.la