summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorRobert Foss <robert.foss@collabora.com>2016-07-27 13:17:42 -0400
committerDaniel Vetter <daniel.vetter@ffwll.ch>2016-08-04 13:13:05 +0200
commit6e89ee8f20fddc6621eb5326ae3b7a75faa749b9 (patch)
tree891b6ff7385a41f4fc52da3210101961480f9cff /lib/Makefile.am
parentcd86866dec7ead650a1811259d9207060034482f (diff)
lib/stubs: Add stubs for intel_bufmgr
This patch provides stubs for functionality otherwise provided by intel_bufmgr. The stubbed functions all fail with a call to igt_require_f(false,""). Defines and enums have been copied from libdrm_intel. Due to the stubbed tests failing with an igt_require_f() call, these stubs are not well suited for non-tests, since tools/benchmarks/etc 'skipping' execution is unhelpful. Signed-off-by: Robert Foss <robert.foss@collabora.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index d2ae98df..365d7d9d 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -14,6 +14,12 @@ if HAVE_LIBDRM_VC4
igt_vc4.h
endif
+if !HAVE_LIBDRM_INTEL
+ libintel_tools_la_SOURCES += \
+ stubs/drm/intel_bufmgr.c \
+ stubs/drm/intel_bufmgr.h
+endif
+
AM_CPPFLAGS = -I$(top_srcdir)
AM_CFLAGS = $(CWARNFLAGS) $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(LIBUNWIND_CFLAGS) $(DEBUG_CFLAGS) \
-DIGT_SRCDIR=\""$(abs_top_srcdir)/tests"\" \