summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2016-03-22 11:33:41 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2016-03-24 11:25:38 +0000
commit756f3e0cb7e7d7351e3eb955ca782a438c6aa887 (patch)
treec1673509c3b101aa70b03408e252e4cb97021308 /lib/Makefile.am
parenteb572106b4721dcfb6bf873ae40c5200f5369039 (diff)
lib: Add a GPU error detector
If we listen to the uevents from the kernel, we can detect when the GPU hangs. This requires us to fork a helper process to do so and send a signal back to the parent. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index a8a1eb6d..d2f2e16b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -15,12 +15,20 @@ if HAVE_VC4
endif
AM_CPPFLAGS = -I$(top_srcdir)
-AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(LIBUNWIND_CFLAGS) $(DEBUG_CFLAGS) \
+AM_CFLAGS = $(CWARNFLAGS) $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(LIBUNWIND_CFLAGS) $(DEBUG_CFLAGS) \
-DIGT_SRCDIR=\""$(abs_top_srcdir)/tests"\" \
-DIGT_DATADIR=\""$(pkgdatadir)"\" \
-DIGT_LOG_DOMAIN=\""$(subst _,-,$*)"\" \
-pthread
-LDADD = $(CAIRO_LIBS) $(LIBUNWIND_LIBS) $(TIMER_LIBS) -lm
AM_CFLAGS += $(CAIRO_CFLAGS)
+libintel_tools_la_LIBADD = \
+ $(DRM_LIBS) \
+ $(PCIACCESS_LIBS) \
+ $(CAIRO_LIBS) \
+ $(LIBUDEV_LIBS) \
+ $(LIBUNWIND_LIBS) \
+ $(TIMER_LIBS) \
+ -lm
+