summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2014-12-02 10:54:54 +0000
committerThomas Wood <thomas.wood@intel.com>2014-12-11 17:55:15 +0000
commit8161a21762b552d97fe6bde8d4fd441d9cd10f61 (patch)
treeddab7ee124f986af4451508c44890c2ce87bc4c1 /lib/Makefile.am
parent85b74d5c14506bbae53ab02408102645e071a206 (diff)
lib: introduce log domains
Log domains can be used to identify the source of log messages, such as the test being run or the helper library. v2: Add separate domains for different parts of the helper library and use an empty default domain for applications. Expand the log output to include the process name and the log level of the message in addition to the domain and pid. Print the expanded message only for warning and debug messages. v3: check for glibc before using program_invocation_short_name Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ab82302c..3826a1cb 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -10,7 +10,8 @@ noinst_HEADERS = check-ndebug.h
AM_CPPFLAGS = -I$(top_srcdir)
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) \
- -DIGT_DATADIR=\""$(abs_top_srcdir)/tests"\"
+ -DIGT_DATADIR=\""$(abs_top_srcdir)/tests"\" \
+ -DIGT_LOG_DOMAIN=\""$(subst _,-,$*)"\"
LDADD = $(CAIRO_LIBS)