summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2017-04-12 12:33:12 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2017-06-07 13:28:13 +0300
commita702b60782d713ebce9199b0007d8beb083e49fe (patch)
treec3c07ce00d1583ef52b2a2e57d5f33f6532187fa /lib/Makefile.am
parentd7d3f4e87b827152f00bdf89a67871736672b492 (diff)
chamelium: Fix build issues on Android
Makefile.sources are included 1:1 in Android.mk files, and are not parsed by automake. And yet those had some automake conditional logic. Moving it to .am file is enough for now. Also igt_chamelium.h included config.h without proper "HAVE_CONFIG_H" guard, and the file itself was included unconditionally. Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Michal Wajdeczko <michal.wajdeczko@intel.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c0ddf298..91e72c44 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -22,6 +22,13 @@ if !HAVE_LIBDRM_INTEL
stubs/drm/intel_bufmgr.h
endif
+if HAVE_CHAMELIUM
+lib_source_list += \
+ igt_chamelium.h \
+ igt_chamelium.c \
+ $(NULL)
+endif
+
AM_CPPFLAGS = -I$(top_srcdir)
AM_CFLAGS = \
$(CWARNFLAGS) \