summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2018-05-06 23:10:35 +0100
committerLionel Landwerlin <lionel.g.landwerlin@intel.com>2018-05-07 15:04:23 +0100
commit1bb318b32db003a377da14715c7b80675a712b6b (patch)
treefa75347c1f49068786cf19afa26c278e5f99d5e3 /lib/meson.build
parent8bde13ad8c4a5652b5ff67782ecbf2dde21faebf (diff)
lib: create new dependency for aubdump
While trying to capture an aubdump on a libva demo, I run into a crash in intel_batchbuffer.c. Turn out every driver has it's own intel_batchbuffer.c with similar symbols and because aubdump pulls in libigt, things go wrong. One could argue that there is something wrong with intel-vaapi-driver's build but I also think aubdump should embed as little as possible. This change creates a very small library that embeds just the needed bits of igt for aubdump. Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Reviewed-by: Katarzyna Dec <katarzyna.dec@intel.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 5f2567fb..04d550fa 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -124,10 +124,17 @@ lib_igt = declare_dependency(link_with : lib_igt_build,
igt_deps = [ lib_igt ] + lib_deps
+lin_igt_chipset_build = static_library('igt_chipset',
+ ['intel_chipset.c',
+ 'intel_device_info.c'],
+ include_directories : inc)
+
+lib_igt_chipset = declare_dependency(link_with : lin_igt_chipset_build,
+ include_directories : inc)
+
lib_igt_perf_build = static_library('igt_perf',
['igt_perf.c'],
- include_directories : inc
-)
+ include_directories : inc)
lib_igt_perf = declare_dependency(link_with : lib_igt_perf_build,
include_directories : inc)