summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-02-20 11:00:21 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-02-23 12:17:46 +0200
commit4d2af5c79d60d6dcdba0bfdddf7d73ab6ac78f89 (patch)
tree5cc91f6b604356443770b146ff0124f71c53cb24 /lib/meson.build
parent1fb30f1131d2a31d0752a73929ca247708d471e4 (diff)
meson: Use bufmgr stubs headers if libdrm_intel is not found
Just adding the .h file to lib_headers is not enough. With this change we are passing 'stubs/drm' as a part of include_directories when building, so a proper -I will be issued to the compiler. This can be done by turning 'inc' into a list of include_directories()-generated objects. Cc: Liviu Dudau <liviu.dudau@arm.com> Cc: Eric Anholt <eric@anholt.net> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com> Tested-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 6c77e407..8f14f632 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -123,6 +123,7 @@ if libdrm_intel.found()
else
lib_headers += 'stubs/drm/intel_bufmgr.h'
lib_sources += 'stubs/drm/intel_bufmgr.c'
+ inc = [ inc, include_directories('stubs/drm') ]
endif
if valgrind.found()