summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorThierry Reding <treding@nvidia.com>2017-10-12 10:33:37 +0200
committerThierry Reding <treding@nvidia.com>2017-11-06 15:58:39 +0100
commit4fbb4b9c12d1944e5d60bc4f3d0cbd0bf7bed36d (patch)
treea831698b103e92a6090ea72cb78a608510fdb13e /lib/meson.build
parent7d2758f25d9c94e8a597718535857c586c3ca21c (diff)
lib: Fix compilation on non-x86
The meson build avoids the failure by excluding the igt_x86.c file from the compilation. autotools being what they are don't support that in an easy way, so just use the preprocessor to avoid the duplicate function definitions. Since igt_x86.c will now be ignored for non-x86 builds, the meson work- around can be removed. Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com> Signed-off-by: Thierry Reding <treding@nvidia.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/lib/meson.build b/lib/meson.build
index b31c68e4..ddf93ec6 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -64,6 +64,7 @@ lib_sources = [
'igt_syncobj.c',
'igt_sysfs.c',
'igt_vgem.c',
+ 'igt_x86.c',
'instdone.c',
'intel_batchbuffer.c',
'intel_chipset.c',
@@ -96,10 +97,6 @@ lib_sources = [
'igt_kmod.c',
]
-if ['x86', 'x86_64'].contains(host_machine.cpu_family())
- lib_sources += 'igt_x86.c'
-endif
-
lib_deps = [
cairo,
glib,