summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorNicholas Kazlauskas <nicholas.kazlauskas@amd.com>2019-04-02 13:45:22 -0400
committerNicholas Kazlauskas <nicholas.kazlauskas@amd.com>2019-04-10 08:53:21 -0400
commita1701d0bb565de68d2db279fdf4f95ecb0e61c59 (patch)
treee31c047d05df9c3fa705fa8a2242795793d62538 /lib/meson.build
parent256c6107ee127d2ff07d23dfeb3b8d828cb43b37 (diff)
lib/igt_fb: Create AMD YUV buffers with AMD GEM IOCTL
The kmstest_dumb_create API isn't suitable for creating multi-planar buffers since it tries to calculate the size based on the first plane's pitch only. AMDGPU requires that the luma pitch be aligned to 256 for YUV buffers which results in crashes on kms_plane@pixel-format-pipe-*-planes tests when using kmstest_dumb_create since the buffer returned is smaller than needed (16384 size returned, 24576 size required). Create and map the buffer with the correct size by using the AMD helpers introduced by this patch: igt_amd_create_bo and igt_amd_mmap_bo. Cc: Harry Wentland <harry.wentland@amd.com> Cc: Leo Li <sunpeng.li@amd.com> Signed-off-by: Nicholas Kazlauskas <nicholas.kazlauskas@amd.com> Reviewed-by: Leo Li <sunpeng.li@amd.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 89de06e6..a8462933 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -54,6 +54,7 @@ lib_sources = [
'igt_v3d.c',
'igt_vc4.c',
'igt_psr.c',
+ 'igt_amd.c'
]
lib_deps = [