summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorSimon Ser <simon.ser@intel.com>2019-04-16 14:27:46 +0300
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2019-04-17 08:21:33 +0300
commita2fd0489c87a4d647c339f98057e6a1550e0e2f5 (patch)
tree1761b7e9f7e99bf225243755893abe241925d45f /lib/meson.build
parente03d0030391689cfd0fbca293d44d83dd7d9e356 (diff)
lib/igt_edid: new library for generating EDIDs
For the purposes of testing different EDID features, we need to generate more and more complex EDID blobs (e.g. with audio support). However currently IGT uses a macro-based system to generate EDIDs. This doesn't scale well and is pretty inflexible. This commit introduces a new little library to generate EDIDs. For now it can't do more than the old macro. Future commits will extend the API. The structures are mostly based on the Linux kernel code (drm_edid.h). Setters have been added for convenience. Signed-off-by: Simon Ser <simon.ser@intel.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/meson.build b/lib/meson.build
index a8462933..20c0e3e6 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -54,7 +54,8 @@ lib_sources = [
'igt_v3d.c',
'igt_vc4.c',
'igt_psr.c',
- 'igt_amd.c'
+ 'igt_amd.c',
+ 'igt_edid.c',
]
lib_deps = [