summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2017-11-10 12:39:56 -0800
committerEric Anholt <eric@anholt.net>2017-11-21 09:52:52 -0800
commitd21e95ca81da6f9332999ceebe6b42e4425d3bb6 (patch)
treeec5ea9f9fb7aba73bbed7836be9d7668e3a45b6b /lib/meson.build
parent4eb53c7cc02a36a23c33f786cb20bf078719f40e (diff)
tests: Remove libdrm_vc4 dependency.
The autotools build retains the configure.ac option, while meson folds vc4 into the default build since we don't have any meson_options.txt to control parts of the build. Signed-off-by: Eric Anholt <eric@anholt.net> Acked-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/lib/meson.build b/lib/meson.build
index ddf93ec6..253548dc 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -47,6 +47,7 @@ lib_headers = [
'igt_dummyload.h',
'uwildmat/uwildmat.h',
'igt_kmod.h',
+ 'igt_vc4.h',
]
lib_sources = [
@@ -95,6 +96,7 @@ lib_sources = [
'igt_dummyload.c',
'uwildmat/uwildmat.c',
'igt_kmod.c',
+ 'igt_vc4.c',
]
lib_deps = [
@@ -118,10 +120,6 @@ else
lib_sources += 'stubs/drm/intel_bufmgr.c'
endif
-if libdrm_vc4.found()
- lib_headers += 'igt_vc4.h'
- lib_sources += 'igt_vc4.c'
-endif
if valgrind.found()
lib_deps += valgrind
endif