summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@bootlin.com>2018-10-04 14:39:01 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-10-08 16:54:06 +0300
commitddb382855e25cd0fd81c56f75f380d4c4422fbad (patch)
treeebd4479f475f236820ce1ccc3717373680634767 /lib/meson.build
parente3b1c3498abf54377245e6d298b4cbcef663d8b4 (diff)
igt: Make pixman mandatory
So far, pixman was used exclusively when the Chamelium support was enabled. However, since we're going to use it as one of the backend to do the igt_fb conversions between formats, we'll need it all the time. Make that explicit. Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/meson.build b/lib/meson.build
index e60e5e02..7e2c9b7a 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -66,6 +66,7 @@ lib_deps = [
math,
realtime,
ssl,
+ pixman,
]
if libdrm_intel.found()
@@ -79,8 +80,8 @@ if valgrind.found()
lib_deps += valgrind
endif
-if gsl.found() and pixman.found()
- lib_deps += [ gsl, pixman ]
+if gsl.found()
+ lib_deps += [ gsl ]
lib_sources += [ 'igt_frame.c', 'igt_audio.c' ]
endif