summaryrefslogtreecommitdiff
path: root/lib/tests/meson.build
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2019-02-19 08:57:15 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2019-02-20 13:58:04 +0100
commit84096969b59b3230a4f890109eb3c6406a37255b (patch)
treeab8ac42752aa2d80982137074166c81641daace8 /lib/tests/meson.build
parentfd8f161877ee496676fd7dd3109823a02a74283f (diff)
lib/tests: Convert no_exit tests into positive tests
This way we can make sure they die with an assert, which is what we want. Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
Diffstat (limited to 'lib/tests/meson.build')
-rw-r--r--lib/tests/meson.build17
1 files changed, 8 insertions, 9 deletions
diff --git a/lib/tests/meson.build b/lib/tests/meson.build
index 665ad4a0..776b63ed 100644
--- a/lib/tests/meson.build
+++ b/lib/tests/meson.build
@@ -1,21 +1,20 @@
lib_tests = [
- 'igt_fork_helper',
+ 'igt_assert',
+ 'igt_can_fail',
+ 'igt_can_fail_simple',
+ 'igt_exit_handler',
'igt_fork',
+ 'igt_fork_helper',
+ 'igt_hdmi_inject',
'igt_list_only',
+ 'igt_no_exit',
+ 'igt_segfault',
'igt_simulation',
'igt_stats',
- 'igt_segfault',
'igt_subtest_group',
- 'igt_assert',
- 'igt_exit_handler',
- 'igt_hdmi_inject',
- 'igt_can_fail',
- 'igt_can_fail_simple',
]
lib_fail_tests = [
- 'igt_no_exit',
- 'igt_no_exit_list_only',
'igt_no_subtest',
'igt_simple_test_subtests',
'igt_timeout',