summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2018-08-31 08:23:53 -0700
committerLucas De Marchi <lucas.demarchi@intel.com>2018-09-11 16:33:08 -0700
commitc7fa2ea9fbce87206474748100b825558eebe08e (patch)
treee976ea606a719a2d8c786156a4d0f7dae4ec44c3 /man/meson.build
parent20a7ead8bdf09774c7d58fcbe6a0980d08ed5365 (diff)
build: allow to use rst2man from python3
While changing maintainer-tools to allow to use python3 I unsintalled my python2 tools, which broke IGT build for me. Allow to use either rst2man-3 or rst2man. v2: remove changes to autotools Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com> Acked-by: Jani Nikula <jani.nikula@linux.intel.com>
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/man/meson.build b/man/meson.build
index fa01f9dd..a6b08900 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -22,14 +22,14 @@ defs_rst = configure_file(input : 'defs.rst.in',
output : 'defs.rst',
configuration : config)
-rst2man = find_program('rst2man', required : _man_required)
+rst2man = find_program('rst2man-3', 'rst2man', required : _man_required)
rst2man_script = find_program('rst2man.sh')
if _build_man and rst2man.found()
foreach manpage : manpages
custom_target(manpage + '.1',
build_by_default : true,
- command : [ rst2man_script, '@INPUT@', '@OUTPUT@' ],
+ command : [ rst2man_script, rst2man, '@INPUT@', '@OUTPUT@' ],
depend_files : [ defs_rst ],
input: manpage + '.rst',
output : manpage + '.1.gz',