summaryrefslogtreecommitdiff
path: root/overlay/Makefile.am
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-10-10 08:22:30 +0100
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-11-22 11:19:14 +0000
commit273e66baef8bf930959c503041b68411bb42ff80 (patch)
treef5e331f8979540cd1488597c491c5380fcd55f4a /overlay/Makefile.am
parent0d8385a7ad670e96dadef6e04e7541a64b637406 (diff)
intel-gpu-overlay: Use RAPL PMU for power reading
Wire up to the RAPL PMU for GPU energy readings. The only complication is that we have to add code to parse: # cat /sys/devices/power/events/energy-gpu.scale 2.3283064365386962890625e-10 v2: Link with -lm. v3: strtod can handle scientific notation, even though my initial reading of the man page did not spot that. (Chris Wilson) v4: Meson fix. Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'overlay/Makefile.am')
-rw-r--r--overlay/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/overlay/Makefile.am b/overlay/Makefile.am
index cefde2d0..f49f54ac 100644
--- a/overlay/Makefile.am
+++ b/overlay/Makefile.am
@@ -63,7 +63,7 @@ intel_gpu_overlay_SOURCES += \
intel_gpu_overlay_SOURCES += $(both_x11_sources)
-intel_gpu_overlay_LDADD = $(LDADD) -lrt
+intel_gpu_overlay_LDADD = $(LDADD) -lrt -lm
EXTRA_DIST= \
README \