summaryrefslogtreecommitdiff
path: root/overlay/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-08-22 15:07:48 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-08-22 15:28:02 +0100
commit7c52a3cf5243b42b632fd73789d1b484e81b9b0c (patch)
tree7d303d347fd1d3201801486d676bbae246fab35f /overlay/Makefile.am
parent184786988e5d78ae230139d76691b9ce7f97dca6 (diff)
overlay: Rudiments of config files and option parsing
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'overlay/Makefile.am')
-rw-r--r--overlay/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/overlay/Makefile.am b/overlay/Makefile.am
index 75a3338a..52a61270 100644
--- a/overlay/Makefile.am
+++ b/overlay/Makefile.am
@@ -8,10 +8,9 @@ LDADD = $(DRM_LIBS) $(PCIACCESS_LIBS) $(CAIRO_LIBS) $(OVERLAY_LIBS)
intel_gpu_overlay_SOURCES = \
i915_pciids.h \
- overlay.h \
- overlay.c \
chart.h \
chart.c \
+ config.c \
cpu-top.h \
cpu-top.c \
debugfs.h \
@@ -26,6 +25,8 @@ intel_gpu_overlay_SOURCES = \
gpu-freq.c \
igfx.h \
igfx.c \
+ overlay.h \
+ overlay.c \
power.h \
power.c \
rc6.h \
@@ -33,6 +34,7 @@ intel_gpu_overlay_SOURCES = \
$(NULL)
if BUILD_OVERLAY_XLIB
+both_x11_sources = x11/position.c x11/position.h
AM_CFLAGS += $(OVERLAY_XLIB_CFLAGS)
LDADD += $(OVERLAY_XLIB_LIBS)
intel_gpu_overlay_SOURCES += \
@@ -41,6 +43,7 @@ intel_gpu_overlay_SOURCES += \
endif
if BUILD_OVERLAY_XVLIB
+both_x11_sources = x11/x11-position.c
AM_CFLAGS += $(OVERLAY_XVLIB_CFLAGS)
LDADD += $(OVERLAY_XVLIB_LIBS)
intel_gpu_overlay_SOURCES += \
@@ -52,4 +55,6 @@ intel_gpu_overlay_SOURCES += \
$(NULL)
endif
+intel_gpu_overlay_SOURCES += $(both_x11_sources)
+
EXTRA_DIST=README